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Introduction




What is XYN Motion Studio?

Next Dimension" of Creativity

XYN Motion Studio is an integrated application leveraging the motion capture tool "mocopi®.” Supporting
capture, timeline editing, and utilization, XYN Motion Studio streamlines the production process by making

motion production easier.

This guide describes the major operations and specifications of the app.
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XYN Motion Studio app structure

“XYN Motion Studio” contains capture function equivalent to the “mocopi PC".
This User Guide explains “Motion Edit".
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Top Menu

Reset Camera button
Side Panel

3D Work area

Timeline

Search area

Play/Stop button
Playback range selector

Scale slider
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Basic Operations

Launching App

Initial startup:

1.
2.

Download "XYN Motion Studio” from the Microsoft Store.

Select the "XYN Motion Studio” icon from the Start menu to launch
the application

Select your place of residence and click on [Start].

Read the displayed message. If you agree, select the checkbox and
click on [Proceed].

Click on [Sign In].

An external browser will launch, and the Microsoft account sign-in
screen will appear.

Log in with a personal Microsoft account. If you're already logged in,
simply select the corresponding account.

Note: Organization accounts, such as those for work or schoaol,
cannot be used to log in.

After successful login, you can close the browser and return to the
App.
Click on [Start Creating].

Second time and after:

1.

2.

Select the "XYN Motion Studio" icon from the Start menu to
launch the application

Click on [Sign In].



Basic Operations

Search Motion By Text

Search

1.

Enter your text in the search
area.

Press the enter key.

Once search results are ready,
they will be displayed on the
left side of the app.

Each individual search result
can be viewed in detail, you
can navigate within the 3D
space of each result, in a
similar way to what is
described in the Moving the
3D Camera section.
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Basic Operations

Search Motion By Text

Reviewing and Selecting ’ 5 ‘B ==
Project Personal Oowd
Search Results — =
1. Results will begin to be
dynamically loaded, and 3 i A T
results will populate on the N ? (I sowmpmmniva  o00028

screen, 4 at a time.

2. Use the pagination buttons at
the bottom to navigate : - -
through the pages of results. | e | a1 v

3. Click on [Add] to add the clip
to the project. The clip will be
added to the [Project] tab, ,
and [Add] will change o o
to \/ . \ 1}

4. Clipswith 7 are listed in ‘ ‘
the [Project] tab. Clickingon +/
again will delete the clip from

the project. _ | a4
5. To return to the Home Screen, 2
users will click the “X" in the I I

upper right-hand corner Of ERNEEEEEEEEREREREN 11 IEEEEREN 11 1 11 | ] I 11 11 I | N R R R R R A R R R
the Search Motion Results
Window.



Basic Operations

Importing Motion

To import motion:

1. From XYN Motion Studio's Top Menu, click on [File] >
[Import Motion(s)].

2. Using the File browser popup, navigate and find the BVH
file(s) you want to import.

3. With the file(s) selected, Press [Open].

4. If the import is successful, new clip(s) will be added to the
[Project] tab in the Side Panel. The added files can be
dragged into the 3D work area or the timeline for use.

Note: Motion data (BVH, FBX) created with mocopi is
supported.

File v Settings v

New Project 1

Save Project

Save Project As

Quit Motion Studio

“ox Import Motion File
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Basic Operations

Tween between two motions

Clip Tween

1.
2.
3.

= o s

Note:

Tips :

Have two motions in the timeline.
Use the Clip/Pose switching button to switch to [Clip].

Set the desired position/rotation of the avatar for each
motion in the Work Area.

Set the distance between clips in number of frames.
Left click on the two clips to highlight them.
Press the [Tween] button.

Review the Tween result. If desired, adjust distance
between clips, and/or avatar distance in space.

You can Tween up to 89 frames.

The number shown in the rectangle is the distance
between clips and can be manually entered for precise
spacing.

Tween will work if only 2 clips are selected and the

distance between them is within the frame limit above.

13

Flename Dwration
[F] dunce vopon (mas 020wt 00:00:08

Y (] stumbie, o, anct ma fpov..  00:00.05




Basic Operations

Tween between two motions

Pose Tween

1.
2.
3.

Have two motions in the timeline.
Use the Clip/Pose switching button to switch to [Pose].

Set the desired position/rotation of the avatar for each
motion in the Work Area.

Set Posel and Pose2 markers which will be the In and Out
poses for the Tween.

Press the [Tween] button.

Review the Tween result. If desired, adjust In/Out frames,
avatar distance, and/or clips.

You can Tween up to 89 frames.

Users can press “1" & “2" to place &/or remove markers on
the timeline.

To clear all pose markers, press the Escape key.

The number shown in the rectangle is the distance
between clips and can be manually entered for precise
spacing.

Tween will only work if the Pose markers are set on two
different clips and the distance between the markers is
within the limit above.
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Basic Operations

Exporting the timeline

To export the motion data in the timeline:
1. From the Top Menu, click on [File] > [Export Motion(s)].

2. On the [Export Settings] dialog, click on the Directory field,
to open File Explorer.

3. Navigate to the folder where you would like to save the
file and click on "Select Folder.”

4. After selecting a folder, enter a file name and click on the
[Export] button in the [Export Settings] dialog.

* Exporting does not consider blank frames between clips.

« Depending on what you select in [Source], the range of
motion data to be exported varies as follows.

« [Playback Range] : Corresponds with the playback
range. Refer to "Timeline Operation."

« [Selected Clip] : The selected clip will be exported.
The playback range and trim clip settings will not
be respected. You cannot export multiple clips at
one time.

File v  Settings v

New Project

Open Project

Save Project As
Quit Motion Studio

Playback Range v fox v~ 60 v

2 (=]

Time: 00:00:07 Frames: 460

Export Settings

Playback Range v Jox ~ 60 v
Time: 00:00:07 Frames: 460
C:\Users\BVH -
sample |
4 =)=
- -,
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Basic Operations

Saving your project

To save the current state of the timeline as well as
all your imported files:

1. From the Top Menu, click on [File] > [Save Project] or [Save
Project As]. If you click on [Save Project] and the project
has been saved previously, it will be overwritten with the
same file name.

2. In the File Explorer window that will open up, navigate to
the folder where you would like to save the project.

3. Enter your desired project name.
4. Click on the [Save] button.
Note: when you're working on a previously saved

project , you need to manually save any changes you
make after saving, as Autosave is not implemented.

File v  Settings v

New Project

Open Project

Import Motion(s)

Quit Motion Studio

don Save Project File

Projects

' Downloads

A Hide Folders
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Basic Operations

Opening a saved project

To load a XYN Motion Studio project and get your
project timeline and imported files:

1.
2.

From the Top Menu, click on [File] > [Open Project].

In the File Explorer window that will open up, navigate to
the folder where your project was saved.

Click on the [Open] button.

The clips, their positions, the files imported to the
[Project] tab, etc., will be restored to their state at the time
of saving.

File v  Settings v

Open Project
s ;

Export Motion(s)

Save Project
Save Project As
Quit Motion Studio

“= Open Project File

» Documents > Projects

Organize » New folder
Projects

v Downloads MyProject.mspj

Bl This PC
%= Windows (C3)

_ Libraries

File name: | MyProject.mspj
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Functional Descriptions

Moving the 3D camera

To Move the 3D camera:

1.

While holding the right mouse button over the viewport,

use the AWSD keys to move left/forward/backward/right
respectively. You can also use the mouse scrolling wheel

to move the camera forward/backwards.

Users can also use the QE Keys to move the plane
up/down while holding down the mouse right button.

The scroll wheel will zoom in/out.

The user can rotate the camera view by holding down the
right mouse button and moving the mouse left and right.

The user can keep the mouse scrolling wheel pressed and
move the plane up, down, left and right, by moving the
mouse forward, backward, left and right respectively.

The user can reset the 3D camera view to its original state
by pressing the Reset Camera button on the top right
corner of the 3D work area.

19




Functional Descriptions

Timeline Operation

Timeline Operation:

The Timeline has multiple functionalities which will be
outlined within the next few pages.

* Playback:

* To play/stop motion, click on the Play/Stop button
on the bottom left of the screen.

—1-

Dmrrent Frame: 147 Curr
IIIIIIIIIIIIIIIII|I
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Scrubbing:

1. You can drag the blue Playhead icon to scrub
through a motion clip.

| 2 Current Frame: 147 Current Time: 00:02 Playback start f

[

stumble, fall, and walk (person)_002.bvh

2. Hotkeys:
+ Left Arrow: step back one frame
» Right Arrow: step forward one frame

* Up Arrow: step forward to the end of the
current clip or start of the next clip.

» Down Arrow: step back to the start of the
current clip or end of the previous clip.

+ Home: go toframe O
* End: go to the last playable frame.
» Scroll wheel: timeline zoom in/out



Functional Descriptions
Timeline Operation

. — A I Tween [ 0 ==

» Adjusting playback range: > curen

. . ]
Theplaybackrange|Sdef|nedby‘therangeselector R R o O O O N N ey El (RN R RN N N NN NN
above the frame-marker area. l J l J

» Drag the sliders on either end to set your start/end
points for playback. Playback will automatically
loop respecting the set range.

. Trim CllpS » Current Frame: 151 Current Time: 00:02 A — A [+l Tween - Pose

« To trim clips, hover your mouse on the start/end of
a clip, you will see your cursor change its icon to
indicate you are about to trim.

« With the trim icon visible, click and drag your
mouse right and/or left accordingly to perform a
trim operation.

T I A | trrrrrrrreerrrigi il Il inigl

(-‘I
> )
dll, and walk (person)_00

Note: Trim is non-destructive and you can always
un-trim your clip to its original state (manually or
using Ctrl+2Z).
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Functional Descriptions

Timeline Operation

« Selecting clips in the [Project] tab: B o personalCloud
« Shift + Select will choose all files within the range.
« Ctrl + Select will choose only the files users select.

' ® Bl conce potiwud (man). 006 vh  00:00:06

* Importing clips into the timeline:

« Select one or more clips in the [Project] tab and
drag them into the 3D work area or the timeline
area to import them.

* C(lips dropped in the 3D work area will be added
after the last clip on the timeline.

* C(lips dropped in the timeline area directly can be
placed at a specific frame position if there's
enough space available for them.

—e—( |
p——— |

frame: 0 Playback end frame: 100 - — A [+ Tween B rose
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Functional Descriptions

Timeline Operation

Moving clips in the timeline:

* To move clips, use the left button of the mouse to
select the clip and while keeping the button
pressed, drag the clip(s) left/right on the timeline.

Notes: :

Clips being moved do not displace other clips in
the timeline.

Clips being moved need an empty space on the
timeline to be dropped in place successfully,
otherwise, clips will go to the end of the timeline.

If you drop one clip on top of another clip, the clip
being dropped will reset to its previous position.

Moving one clip right at the end of the timeline will
make the timeline expand to fit the new position of
the dragged clip.

Deleting Clips:

To delete a clip, first select it (mouse left button).
Selected clips show highlighted white.

10:02 Playback start frame: 13 Playback end frame: 1150 -~ e—

U LIl L e Uil U (0 s 0 L oL s 0 il L S e Lt e (b et i et it (b A

MR ]

sample sample2

Press the Delete key on your keyboard. Pressing
Ctrl + Z will undo this action.
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2:02 Playb; “tframe: 13 Playback end frame: 1150 - emm— 9 A |+ Tween

| 1AL S LS b s 0 R (R s S ST P sl Pt 8 e It e 8 R 00 £ 560 3 0 008 6 et | L 0 6 0 0 1 00 £ 3 0 4
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)02 Playback start frame: 13 Playback end frame: 1150 - e— A [~| Tween
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Functional Descriptions

Timeline Operation

* Zoom|ng |n P CurentFrame: 620 CumentTime: 0010  Playback start frame: 106 Playback end fame: 647 » e— & N Tween [ rose
. . . . [ |
|nSomeCaSGS,yoqu”Wanttozoom|nthet|me||net0 I|Illll||IIIIIIIIIIII|IIXII|IIlllllllllllllllllllllllrlllvl‘1rI'I:Il)llllllllx(llIIIIIIKIlll|Ill|l||
get a more granUIar lOOk at the mOtlon [smmow_wl_»awy-(pmmloozm ] a [vl‘.nosbotla(eandm1m.ln)oolmn }
* To zoom in/out, hover your mouse anywhere on —
the timeline and use your mouse’s scroll wheel. P Curentfame: 620 CorentTime: 0090  Playbock stat fame: 106 Playback end frame: 647 « @ & | ] Tween [ Fose
9

1 1 | 1 1

« Alternatively, you can use the scale slider on the S ) | S| | S T S| . L
bottom right.

Notes: :

* Zoom in/out will be centered on the Playhead's
position.

* Panning:

* The timeline automatically pans to keep the
Playhead visible during playback.



Functional Descriptions

Positioning Avatar

Set the desired
position/rotation on each

motion.
1.

To apply individual position
and rotation to each motion,
first place the Playhead within
the motion clip you want to
modify. (this will be your
active clip).

Click on the Avatar to bring up
the Transform Gizmo.

Use the Gizmo to modify the
position and rotation of the
origin of the animation.

Repeat as needed for the
second clip.

To verify, press Play on the
timeline. Each animation clip
will now respect the
transform settings you
applied.

xi‘
‘fz

| 4 Current Frame;_12!
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Functional Descriptions

Avatar Visual Indicator

Avatar Visual Indicator

a. The Avatar Visual Indicator highlights the start and end
point of the animation, samples the positions of the
avatar in the animation, and the hip direction of the first,
and last frames of the animation.

b. Avatar Visual Indicators will only become visible after an
animation is played in the timeline.

¢. The visual indicators of inactive animation clips are
grayed out, allowing users to align their active clip with
other clips in the timeline.

d. Before initiating a Tween, a dashed line will appear to
visualize the two animations that will be Tweened.

Note: A dashed line will be drawn between the 2 clips
that will be tweened together.

26



Functional Descriptions

Avatar Visual Indicator

Point / End Point / Hip Angle Indicator
The characteristics of each Avatar Visual Indicator
element are as follows.
a. Point

» Point aligns with path. Just identifies beginning and
end of path. Does not show direction of avatar.

b. End Point
« Circular end points (both ends) make alignment
easier.

¢. Hip Angle Indicator

* The Hip directional indicator will NOT be shown,
when the Hip rotation on the degree of motion
considered for the arrow, exceeds +/-70 degrees.

27

] a
: S|,
When rotation exceeds +/-70 When rotation is +/-70
degrees degrees or less
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Functional Descriptions

Setting motion data tags

Confirming suggested tags

a.

b.

When motion data is uploaded to the cloud, the video
content will be analyzed and suggested tags will be
automatically generated.

The suggested tags can be confirmed in the screen that
appears by double-clicking on a file name listed in the
[Project] tab.

Click on & to approve or the x icon to dismiss the
suggested tag.

Tagging manually

a.

In the screen that appears by double-clicking on a file
name listed in the [Project] tab, click on an area where
tags are not displayed and enter the tag name.

N
/i
e | —tt—3
- ( \*:«L\ R\

e [\

po

AL

sample

|man\/ Xl |standup\/ Xl Iﬁeshoelace\/ Xl

¥ Export

il Delete + Add to Project
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Tips

Tweening Effectively

When creating a tween, it is best if the in
& out frames are action frames. This helps
the blending process.

The Tween process is non-destructive, and
users can undo up to 20 actions.

Export the completed animation before
undoing to save the result before
performing the Tween again.

File ~  Settings ~

| 3 Curvert Frame: MY Claent Tame: 0005 Pk

4-_/.(/)
N

start Same: O Playtiack end hame: 751

Mumbre, £, a0 wadk (person; 002 svh

1ot Whowace and Jog [man) 004 bt

| cartune
Project Personal Cowd
& O

T] sturniie, tall, madt watk {poc 00.00.05

r! retie ihowlace and g ima 00.00.05
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Appendix

Specifications

Recommended PC specifications
- CPU
* Intel® Core™ i7-11700
- GPU
*  NVIDIA® GeForce RTX™ 3060
- 0S
«  Windows 10 (64 bit) or higher

Tweening

« Available for up to 89 frames (common to both Clip
and Pose)

Output data

Motion data

File formats

BVH, FBX

Frame rates

241ps, 30fps, 50fps, 60fps
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Appendix
Hot Keys

Avatar Indicator:
I: toggle the visibility of the indicators

Playback Hotkeys:
Space: Play/Stop

Timeline Hotkeys:
Left Arrow: step back one frame
Right Arrow: step forward one frame

Up Arrow: step forward to the end of the current clip or
start of the next clip

Down Arrow: step back to the start of the current clip
or end of the previous clip

Home: go to frame O

End: go to the last playable frame
Scroll wheel: timeline zoom in/out
1. set Pose marker #1

2: set Pose marker #2

Escape: clear pose markers

Clips Hotkeys:
Delete: delete Clip

Undo/Redo:
Ctrl + Z: undo
Ctrl + Y: redo
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